Các bước để upgrade cisco ASA FirePower từ 5.x lên 6.0.0

Các bước để upgrade​​ ​​ cisco ASA FirePower​​ từ 5.x lên​​ ​​ 6.0.0

Link tham khảo:

http://www.thesecurityblogger.com/upgrading-cisco-asa-firepower-5-4-to-6-0-on-5506-5515-experience/

Check bằng lệnh sh module trên ips

Test upgrade bằng giao diện trên asdm xem ok k cả 2 file iso mới down về

Bước 1 check xem ip quản trị là gì gw là gì của ips và firesight

Ips quan tri

Quản trị

10.36.66.209

Sfr console

Quản trị firepower

10.36.66.47

 

Firesight  ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​​​ https://10.36.66.45

Bước 2 upgrade firesight qua giao diện 5.4.1 cũ

Bước 3 config manager add (ipaddress) (key)​​ trong session sfr

configure manager add 10.89.133.202 thesecurityblogger  

update firesight quan trọng

Its recommended to enable rule updates, check for software updates and enable geolocation updates. You do this by going to System-> Updates then select Download Updates. Update will appear and state if they require a reboot. Select the present picture to install. NOTE: A reboot will not reboot the core ASA. Sourcefire has its own processing, CPU, etc and runs inside the ASA similar to a separate virtual machine inside a server. 

: Saved

:​​ 

: Serial Number: FCH1943JAGF

: Hardware:  ​​​​ ASA5525, 8192 MB RAM, CPU Lynnfield 2394 MHz, 1 CPU (4 cores)

:

ASA Version 9.2(2)4​​ 

!

firewall transparent

hostname ciscoasa

enable password​​ xxxxxxxxxxxxxxx​​ encrypted

names

!

interface GigabitEthernet0/0

​​ nameif outside

​​ bridge-group 1

​​ security-level 0

!

interface GigabitEthernet0/1

​​ shutdown

​​ nameif inside

​​ bridge-group 2

​​ security-level 100

!

interface GigabitEthernet0/2

​​ shutdown

​​ no nameif  ​​ ​​​​ 

​​ no security-level

!

interface GigabitEthernet0/3

​​ shutdown

​​ no nameif

​​ no security-level

!

interface GigabitEthernet0/4

​​ shutdown

​​ no nameif

​​ no security-level

!

interface GigabitEthernet0/5

​​ no nameif

​​ no security-level

​​ traffic-forward sfr monitor-only

!

interface GigabitEthernet0/6

​​ shutdown

​​ no nameif

​​ no security-level

!

interface GigabitEthernet0/7

​​ shutdown  ​​ ​​ ​​​​ 

​​ no nameif

​​ no security-level

!

interface Management0/0

​​ management-only

​​ nameif MNGT

​​ security-level 50

​​ ip address 10.36.66.209 255.255.255.0​​ 

!

interface BVI1

​​ ip address 202.9.84.2 255.255.255.0​​ 

!

interface BVI2

​​ ip address 10.36.86.1 255.0.0.0​​ 

!

ftp mode passive

access-list ACL_ANY extended permit ip any any​​ 

access-list outside_access_in extended permit ip any any​​ 

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

mtu MNGT 1500​​ 

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

no arp permit-nonconnected

access-group outside_access_in in interface outside

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

http server enable

http 10.36.66.0 255.255.255.0 MNGT

http 202.9.84.0 255.255.255.0 outside

no snmp-server location

no snmp-server contact

crypto ipsec security-association pmtu-aging infinite

crypto ca trustpool policy

telnet timeout 5

no ssh stricthostkeycheck

ssh 10.36.66.0 255.255.255.0 MNGT

ssh 0.0.0.0 0.0.0.0 MNGT

ssh timeout 30

ssh version 2

ssh key-exchange group dh-group1-sha1

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

username tienvm password KrHQzryU4oOiV6JP encrypted privilege 15

!

class-map SFR

​​ match access-list ACL_ANY

class-map inspection_default

​​ match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

​​ parameters

 ​​​​ message-length maximum client auto

 ​​​​ message-length maximum 512

policy-map global_policy

​​ class inspection_default

 ​​​​ inspect dns preset_dns_map​​ 

 ​​​​ inspect ftp​​ 

 ​​​​ inspect h323 h225​​ 

 ​​​​ inspect h323 ras​​ 

 ​​​​ inspect rsh​​ 

 ​​​​ inspect rtsp​​ 

 ​​​​ inspect esmtp​​ 

 ​​​​ inspect sqlnet​​ 

 ​​​​ inspect skinny ​​ 

 ​​​​ inspect sunrpc​​ 

 ​​​​ inspect xdmcp​​ 

 ​​​​ inspect sip ​​ 

 ​​​​ inspect netbios​​ 

 ​​​​ inspect tftp​​ 

 ​​​​ inspect ip-options​​ 

​​ class SFR

 ​​​​ sfr fail-close

!

service-policy global_policy global

prompt hostname context​​ 

no call-home reporting anonymous

Cryptochecksum:88f404de42fc38dfb887288184e52d1a

: end

 

Asa 2

: Saved

:​​ 

: Serial Number: FCH1943JAHF

: Hardware:  ​​​​ ASA5525, 8192 MB RAM, CPU Lynnfield 2393 MHz, 1 CPU (4 cores)

:

ASA Version 9.2(2)4​​ 

!

hostname OP-FW-Active

domain-name​​ fixloinhanh.com

enable password 8Ry2YjIyt7RRXU24 encrypted

xlate per-session deny tcp any4 any4

xlate per-session deny tcp any4 any6

xlate per-session deny tcp any6 any4

xlate per-session deny tcp any6 any6

xlate per-session deny udp any4 any4 eq domain

xlate per-session deny udp any4 any6 eq domain

xlate per-session deny udp any6 any4 eq domain

xlate per-session deny udp any6 any6 eq domain

names

!

interface GigabitEthernet0/0

​​ nameif outside

​​ security-level 0

​​ ip address 192.168.1.150 255.255.255.0 standby 192.168.1.151​​ 

!

interface GigabitEthernet0/1

​​ nameif inside

​​ security-level 100

​​ ip address 10.36.86.1 255.255.255.0 standby 10.36.86.2​​ 

!

interface GigabitEthernet0/2

​​ description LAN/STATE Failover Interface

!

interface GigabitEthernet0/3

​​ no nameif

​​ no security-level

​​ no ip address

!

interface GigabitEthernet0/4

​​ no nameif

​​ no security-level

​​ no ip address

!

interface GigabitEthernet0/5

​​ shutdown

​​ no nameif

​​ no security-level

​​ no ip address

!

interface GigabitEthernet0/6

​​ shutdown

​​ no nameif

​​ no security-level

​​ no ip address

!

interface GigabitEthernet0/7

​​ shutdown

​​ no nameif

​​ no security-level

​​ no ip address

!

interface Management0/0

​​ management-only

​​ nameif MNGT

​​ security-level 0

​​ ip address 10.36.66.207 255.255.255.0 standby 10.36.66.208​​ 

!

interface Redundant1

​​ member-interface GigabitEthernet0/3

​​ member-interface GigabitEthernet0/4

​​ no nameif

​​ no security-level

​​ no ip address

!  ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​ ​​​​ 

interface Redundant1.76

​​ vlan 76

​​ nameif Routingweb

​​ security-level 50

​​ ip address 10.36.76.1 255.255.255.0 standby 10.36.76.2​​ 

!

ftp mode passive

dns server-group DefaultDNS

​​ domain-name​​ fixloinhanh.com

object network inside

​​ host 10.36.86.150

object network inside2

​​ host 10.36.86.5

access-list inside_access_in extended permit ip any any​​ 

access-list outside_access_in extended permit icmp any any​​ 

access-list​​ fixloinhanh_any extended permit ip any any​​ 

pager lines 24

mtu outside 1500

mtu inside 1500

mtu MNGT 1500

mtu Routingweb 1500

failover

failover lan unit secondary

failover lan interface Fo_Link GigabitEthernet0/2

failover link Fo_Link GigabitEthernet0/2

failover interface ip Fo_Link 10.56.78.1 255.255.255.0 standby 10.56.78.2

no monitor-interface outside

monitor-interface Routingweb

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-752.bin

no asdm history enable

arp timeout 14400

no arp permit-nonconnected

!

object network inside

​​ nat (inside,outside) static 202.9.84.5

object network inside2

​​ nat (inside,outside) static 202.9.84.6

access-group outside_access_in in interface outside

access-group inside_access_in in interface inside

route outside 0.0.0.0 0.0.0.0 192.168.1.1 1

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

aaa authentication ssh console LOCAL​​ 

http server enable

http 0.0.0.0 0.0.0.0 inside

http 192.168.1.2 255.255.255.255 MNGT

http 10.36.66.0 255.255.255.0 MNGT

no snmp-server location

no snmp-server contact

crypto ipsec security-association pmtu-aging infinite

crypto ca trustpoint _SmartCallHome_ServerCA

​​ no validation-usage

​​ crl configure

crypto ca trustpool policy

crypto ca certificate chain _SmartCallHome_ServerCA

​​ certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

 ​​ ​​ ​​​​ 308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130​​ 

 ​​ ​​ ​​​​ 0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117​​ 

 ​​ ​​ ​​​​ 30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b​​ 

 ​​ ​​ ​​​​ 13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504​​ 

 ​​ ​​ ​​​​ 0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72​​ 

 ​​ ​​ ​​​​ 20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56​​ 

 ​​ ​​ ​​​​ 65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043​​ 

 ​​ ​​ ​​​​ 65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31​​ 

 ​​ ​​ ​​​​ 30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b​​ 

 ​​ ​​ ​​​​ 30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20​​ 

 ​​ ​​ ​​​​ 496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65​​ 

 ​​ ​​ ​​​​ 74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420​​ 

 ​​ ​​ ​​​​ 68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329​​ 

 ​​ ​​ ​​​​ 3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365​​ 

 ​​ ​​ ​​​​ 63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7​​ 

 ​​ ​​ ​​​​ 0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597​​ 

 ​​ ​​ ​​​​ a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10​​ 

 ​​ ​​ ​​​​ 9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc​​ 

 ​​ ​​ ​​​​ 7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b​​ 

 ​​ ​​ ​​​​ 15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845​​ 

 ​​ ​​ ​​​​ 63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8​​ 

 ​​ ​​ ​​​​ 18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced​​ 

 ​​ ​​ ​​​​ 4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f​​ 

 ​​ ​​ ​​​​ 81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201​​ 

 ​​ ​​ ​​​​ db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868​​ 

 ​​ ​​ ​​​​ 7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101​​ 

 ​​ ​​ ​​​​ ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8​​ 

 ​​ ​​ ​​​​ 45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777​​ 

 ​​ ​​ ​​​​ 2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a​​ 

 ​​ ​​ ​​​​ 1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406​​ 

 ​​ ​​ ​​​​ 03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973​​ 

 ​​ ​​ ​​​​ 69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403​​ 

 ​​ ​​ ​​​​ 02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969​​ 

 ​​ ​​ ​​​​ 6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b​​ 

 ​​ ​​ ​​​​ c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973​​ 

 ​​ ​​ ​​​​ 69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30​​ 

 ​​ ​​ ​​​​ 1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603​​ 

 ​​ ​​ ​​​​ 551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355​​ 

 ​​ ​​ ​​​​ 1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609​​ 

 ​​ ​​ ​​​​ 2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80​​ 

 ​​ ​​ ​​​​ 4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e​​ 

 ​​ ​​ ​​​​ b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a​​ 

 ​​ ​​ ​​​​ 6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc​​ 

 ​​ ​​ ​​​​ 481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16​​ 

 ​​ ​​ ​​​​ b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0​​ 

 ​​ ​​ ​​​​ 5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8​​ 

 ​​ ​​ ​​​​ 6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28​​ 

 ​​ ​​ ​​​​ 6c2527b9 deb78458 c61f381e a4c4cb66

 ​​​​ quit

crypto ikev1 policy 1

​​ authentication pre-share

​​ encryption 3des

​​ hash sha

​​ group 2

​​ lifetime 86400

telnet timeout 5

ssh stricthostkeycheck

ssh 192.168.1.0 255.255.255.0 outside

ssh 10.36.86.0 255.255.255.0 inside

ssh 10.36.86.111 255.255.255.255 inside

ssh 10.36.66.0 255.255.255.0 MNGT

ssh timeout 30

ssh version 2

ssh key-exchange group dh-group1-sha1

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

username longtn password A8DThGAjQp4.FSbj encrypted privilege 15

username cuongnh password OM54xhb4HAypP7lq encrypted privilege 15

username tienvm password yPGRR0dB/omXxrPN encrypted privilege 15

!

class-map​​ fixloinhanh

​​ match access-list​​ fixloinhanh_any

class-map inspection_default

​​ match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

​​ parameters

 ​​​​ message-length maximum client auto

 ​​​​ message-length maximum 512

policy-map global_policy

​​ class inspection_default

 ​​​​ inspect dns preset_dns_map​​ 

 ​​​​ inspect ftp​​ 

 ​​​​ inspect h323 h225​​ 

 ​​​​ inspect h323 ras​​ 

 ​​​​ inspect ip-options​​ 

 ​​​​ inspect netbios​​ 

 ​​​​ inspect rsh​​ 

 ​​​​ inspect rtsp​​ 

 ​​​​ inspect skinny ​​ 

 ​​​​ inspect esmtp​​ 

 ​​​​ inspect sqlnet​​ 

 ​​​​ inspect sunrpc​​ 

 ​​​​ inspect tftp​​ 

 ​​​​ inspect sip ​​ 

 ​​​​ inspect xdmcp​​ 

​​ class​​ fixloinhanh

 ​​​​ sfr fail-open

!

service-policy global_policy global

prompt hostname context​​ 

call-home reporting anonymous

call-home

​​ profile CiscoTAC-1

 ​​​​ no active

 ​​​​ destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

 ​​​​ destination address email callhome@cisco.com

 ​​​​ destination transport-method http

 ​​​​ subscribe-to-alert-group diagnostic

 ​​​​ subscribe-to-alert-group environment

 ​​​​ subscribe-to-alert-group inventory periodic monthly 27

 ​​​​ subscribe-to-alert-group configuration periodic monthly 27

 ​​​​ subscribe-to-alert-group telemetry periodic daily

Cryptochecksum:3b1362a0d1576a1ad27048cae4a4f1bc

: end

SaKuRai

Xin chào, Mình là Sakurai. Blog này là nơi để note lại và chia sẻ những kiến thức, kinh nghiệm mà mình và anh em trong Team. Cảm ơn các bạn đã quan tâm theo dõi!

You may also like...

Leave a Reply

Your email address will not be published.